艺海股票网

炒股入门

当前位置:首页 > 股票知识 > 股票公式 > 正文

通达信终极无敌指标公式具体分析

2019-03-25 10:51互联网

  VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));

  买盘:=IF((CLOSE 》 OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE 《 OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));

  卖盘:=IF((CLOSE 》 OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE 《 OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));

  买卖差:=(买盘 + 卖盘);

  STICKLINE((买卖差 《 0),0,买卖差,5,0),Color155500;

  STICKLINE((买卖差 《 0),0,买卖差,4,0),Color208000;

  STICKLINE((买卖差 《 0),0,买卖差,3,0),Color2BAA00; STICKLINE((买卖差 《 0),0,买卖差,2,0),Color35D500; STICKLINE((买卖差 《 0),0,买卖差,0.1,0),Color40FF00; JX1:=BARSSINCE(买盘);

  JY1:=IF(((121 》 JX1) AND (JX1 》 0)),JX1,120);

  JY2:=IF(((4 》 JX1) AND (JX1 》 0)),JX1,3);

  VAR30:=MA(VOL,JY2);

  神比:=(买盘 / VAR30);

  鬼比:=(卖盘 / VAR30);

  VAR2:=(HIGH - LOW);

  VAR3:=ABS((OPEN - CLOSE));

  VAR4:=(HIGH - IF((CLOSE 》 OPEN),CLOSE,OPEN));

  VAR5:=(IF((CLOSE 》 OPEN),OPEN,CLOSE) - LOW);

  VAR6:=((VAR3 / VAR2) * VOL);

  VAR7:=((VAR4 / VAR2) * VOL);

  VAR8:=((VAR5 / VAR2) * VOL);

  VAR9:=IF(((VOL / CAPITAL) 》 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));

  VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);

  VARB:=(((MA(CLOSE,5) 》 MA(CLOSE,10)) AND (MA(CLOSE,10) 》 MA(CLOSE,30))) AND (MA(CLOSE,30) 》 MA(CLOSE,60))); VARC:=((MA(CLOSE,5) 《 MA(CLOSE,10)) AND (MA(CLOSE,10) 《 MA(CLOSE,30)));

  VARD:=REF(CLOSE,1);

  VARE:=((SMA(MAX((CLOSE - VARD),0),6,1) / SMA(ABS((CLOSE - VARD)),6,1)) * 100);

  VAR40:=((IF((((VAR6 》= VAR7) AND (VAR6 》= VAR8)) AND (CLOSE 》 OPEN)),VAR6,买盘) + 买盘) / 2);

  VAR41:=((IF(((VAR7 》 VAR6) AND (VAR7 》 VAR8)),VAR7,买盘) + 买盘) / 2);

  VAR42:=((IF(((VAR8 》 VAR6) AND (VAR8 》 VAR7)),VAR8,买盘) + 买盘) / 2);

  VAR50:=((IF((((VAR6 》= VAR7) AND (VAR6 》= VAR8)) AND (CLOSE 《 OPEN)),VAR6,卖盘) + 卖盘) / 2);

  三日上攻:=MA((((VAR40 + VAR41) + VAR42) / 3),JY2);

  三日下攻:=MA(VAR50,JY2); 多头:STICKLINE((CLOSE 》 MA(CLOSE,30)),0,VOL,5,0),Color0000D5;

  多头1:STICKLINE((CLOSE 》 MA(CLOSE,30)),0,VOL,4,0),Color0000FF; 多头2:STICKLINE((CLOSE 》 MA(CLOSE,30)),0,VOL,3,0),Color2B2BFF; 多头3:STICKLINE((CLOSE 》 MA(CLOSE,30)),0,VOL,2,0),Color5555FF; 多头4:STICKLINE((CLOSE 》 MA(CLOSE,30)),0,VOL,0.1,0),Color8080FF; 空头:STICKLINE((CLOSE 《 MA(CLOSE,30)),0,VOL,5,0),Color155500;

  空头1:STICKLINE((CLOSE 《 MA(CLOSE,30)),0,VOL,4,0),Color208000; 空头2:STICKLINE((CLOSE 《 MA(CLOSE,30)),0,VOL,3,0),Color2BAA00; 空头3:STICKLINE((CLOSE 《 MA(CLOSE,30)),0,VOL,2,0),Color35D500; 空头4:STICKLINE((CLOSE 《 MA(CLOSE,30)),0,VOL,0.1,0),Color40FF00; STICKLINE((((VAR6 》= VAR7) AND (VAR6 》= VAR8)) AND (CLOSE 》 OPEN)),0,VAR6,4,0),color00BBFF; STICKLINE((((VAR6 》= VAR7) AND (VAR6 》= VAR8)) AND (CLOSE 》 OPEN)),0,VAR6,3,0),color00CCFF; STICKLINE((((VAR6 》= VAR7) AND (VAR6 》= VAR8)) AND (CLOSE 》 OPEN)),0,VAR6,2,0),color00DDFF; STICKLINE((((VAR6 》= VAR7) AND (VAR6 》= VAR8)) AND (CLOSE 》 OPEN)),0,VAR6,1,0),color00EEFF; STICKLINE((((VAR6 》= VAR7) AND (VAR6 》= VAR8)) AND (CLOSE 》 OPEN)),0,VAR6,0.1,0),color00FFFF;

  STICKLINE((((VAR6 》= VAR7) AND (VAR6 》= VAR8)) AND (CLOSE 《 OPEN)),0,VAR6,4,0),ColorD56A00; STICKLINE((((VAR6 》= VAR7) AND (VAR6 》= VAR8)) AND (CLOSE 《 OPEN)),0,VAR6,3,0),ColorFF8000; STICKLINE((((VAR6 》= VAR7) AND (VAR6 》= VAR8)) AND (CLOSE 《 OPEN)),0,VAR6,2,0),ColorFF952B; STICKLINE((((VAR6 》= VAR7) AND (VAR6 》= VAR8)) AND (CLOSE 《 OPEN)),0,VAR6,1,0),ColorFFAA55; STICKLINE((((VAR6 》= VAR7) AND (VAR6 》= VAR8)) AND (CLOSE 《 OPEN)),0,VAR6,0.1,0),ColorFFBF80;

  STICKLINE(((VAR8 》 VAR6) AND (VAR8 》 VAR7)),0,VAR8,4,0),COLORFFAAFF; STICKLINE(((VAR8 》 VAR6) AND (VAR8 》 VAR7)),0,VAR8,3,0),COLORFFBBFF;

  STICKLINE(((VAR8 》 VAR6) AND (VAR8 》 VAR7)),0,VAR8,2,0),COLORFFCCFF; STICKLINE(((VAR8 》 VAR6) AND (VAR8 》 VAR7)),0,VAR8,1,0),COLORFFDDFF; STICKLINE(((VAR8 》 VAR6) AND (VAR8 》 VAR7)),0,VAR8,0.1,0),COLORFFEEFF; STICKLINE(((VAR7 》 VAR6) AND (VAR7 》 VAR8)),0,VAR7,4,0),ColorD500D5; STICKLINE(((VAR7 》 VAR6) AND (VAR7 》 VAR8)),0,VAR7,3,0),ColorFF00FF; STICKLINE(((VAR7 》 VAR6) AND (VAR7 》 VAR8)),0,VAR7,2,0),ColorFF2BFF;

  STICKLINE(((VAR7 》 VAR6) AND (VAR7 》 VAR8)),0,VAR7,1,0),ColorFF55FF; STICKLINE(((VAR7 》 VAR6) AND (VAR7 》 VAR8)),0,VAR7,0.1,0),ColorFF80FF; STICKLINE((VOL 》 (MA(VOL,5) * 2.5)),0,VOL,2,0),; STICKLINE((VOL 》 (MA(VOL,5) * 2.5)),0,VOL,1.6,0),;

  STICKLINE((VOL 》 (MA(VOL,5) * 2.5)),0,VOL,1.2,0),; STICKLINE((VOL 》 (MA(VOL,5) * 2.5)),0,VOL,0.8,0),; STICKLINE((VOL 》 (MA(VOL,5) * 2.5)),0,VOL,0.1,0),; STICKLINE((买盘 》 0),买盘,0,2,0),color0000AA; STICKLINE((买盘 》 0),买盘,0,1.6,0),color0000BB;

  STICKLINE((买盘 》 0),买盘,0,1.2,0),color0000CC;

  STICKLINE((买盘 》 0),买盘,0,0.8,0),color0000DD;

  STICKLINE((买盘 》 0),买盘,0,0.4,0),color0000EE;

  DRAWTEXT(((DATE 》 700101) AND CROSS(84,VARE)),HIGH,‘卖■出’),COLORFF00FF; 上攻均量:=MA(买盘,JY1);

  下攻均量:=MA(卖盘,JY1);

  DRAWTEXT(((((((((VAR7 》 VAR6) AND (VARA 》 2)) AND (VAR9 》 VAR8)) AND (CLOSE 》 MA(CLOSE,5))) AND (CLOSE 》 MA(CLOSE,30))) AND (HIGH 》 MA(CLOSE,60))) AND (VOL 》 MA(VOL,5))) AND (VAR7 》= MA(VOL,5))),VOL,‘出●货’),COLORFF00FF;

  DRAWTEXT(((((((VAR8 》 VAR6) AND (VAR8 》 VAR7)) AND (VARA 《 (0 - 2))) AND (CLOSE 《 MA(CLOSE,30))) AND (VAR8 《 (MA(VOL,5) / 2))) AND (MA(VOL,5) 《 MA(VOL,10))),VOL,‘低▲进’),colorblue;

  DRAWTEXT((((((VAR6 》 (MA(VOL,5) * 2)) AND (VAR6 》= VAR7)) AND (VAR6 》= VAR8)) AND (CLOSE 》 OPEN)) OR ((VOL 》 (MA(VOL,5) * 3)) AND VARB)),VOL,‘强◆势’),colorblue;

  hsl:=DYNAINFO(37);

  DRAWTEXT((((VOL / REF((SUM(VOL,5) / 5),1)) 》= 2) AND (hsl 》 1)),(VOL * 1.1),‘变★量’),colorblue;

通达信终极无敌指标公式
推荐阅读